Feeds, issues, packages and code source about emulation and pograming, of VENENUX proyects, Debian related distros and massenkoh!

LVM2, dmraid, & write barriers not supported: xfs or ext

|
El núcleo linux 2.6.28 es el ultimo de un tipo de núcleos, debido a que ya 2.6.29 viene con nuevas características implementadas como KMS, viene con cosas nuevas pero, por supuesto, algunas fallas por tantas cosas nuevas, ahora un problema de reciente aparición (hoy resuelto en versiones recientes) relacionados con la escritura por barridas sobre los mapeos de dispositivos la cual no funcionaba, lo que significa que en las implementacion LVM2 tampoco esta funcionando.! Veamos como afecta esto a las versiones Debian recientes!
The 2.6.28 its a last kernel series of kernel types, due over 2.6.29 comes with new features implemented like KMS, comes with new issues but of course and some bugs due those lot of new features, now a recent problem (today solved in lasted releases) related to write barriers that over device mapper are not supported, which means that write barriers over LVM2 are also not supported.! Lest how affect this to Debian fresh releases!
RESUMEN BARRIDO POR ESCRITURAS NO COMPATIBLE EN LENNY Y SQUEEZE
Como sea, en lenny si se utiliza el kernel oficial liberado, es decir 2.6.26, este error no aplica. Sin embargo, afecta directamente a backports para lenny y kernels oficiales para squeeze, cualquier recopilación o liberacion que emplee los núcleos 2.6.33 hasta 2.6.29 heredaran este problema, ya que dmraid requiere funciones relacionadas con el kernel! Este problema se resolvió en versiones 2.6.34 de manera precedida.
El problema es completamente detallado y descrito aquí: https://bugzilla.kernel.org/show_bug.cgi?id=9554 donde se especifica que se relacionan con el soporte del version Linux 2.6.29 en, 2.6.30, 2.6.31 y 2.6.32 del nucleo.
OVERVIEW WRITE BARRIERS NOT SUPPORTED IN SQUEEZE AND LENNY IN LVM

However, on lenny if you use the official kernel release, i mean 2.6.26, this error does not apply. However, directly affects backports packages for lenny and squeeze official kernels, also any compilation or releases that builds over 2.6.29 to 2.6.32 inherit this problem, because dmraid requires kernel-related functions! This problem was fixed in version 2.6.34 and so.

The problem is complete and detailed is described here: https://bugzilla.kernel.org/show_bug.cgi?Id=9554 which specifies that relate to the Linux kernel support on 06/02/1929, 02/06/1930, 02/06/1931 and 06/02/1932 versions only.

COMO RESOLVERLO DEPENDIENDO DE LA VERSION DE DEBIAN?

Esto dependerá de la version del kernel instaladas. Para lenny el kernel oficial lanzado (2.6.28) no se ve afectado, pero el núcleo que esta en backports de lenny sí, ya que son 2.6.32. Los usados en squeeze son inmediatamente afectados ya que la liberación oficial es 2.6.32 o 2.6.33, por supuesto, la solución para la futura squeeze de backports no se verá afectada por que para entonces el núcleo debe ser mayor que la versión 2.6.34.
Se puede utilizar paquetes de testing o sid mayores a 2.6.34 que solucionan el problema

Para etch o lenny, puede usarse la compilacion de kanotix excalibur tambien.

Lo segundo es que solo en squeeze o versiones sid que hayan empleado estos kernels afectados, deben recompilar el paquete lvm2 y dmraid.

AQUI ESTA EL KERNEL 2.6.34 para etch, lenny y squeeze (sin ninguna remocion fnatica GNU y compatible con los paquetes linux-firmwares) deberas usar module-assistant 0.11.3 si instalas y usas estos paquetes de headers
HOW TO SOLVED DEPEND ON DEBIAN RELEASED ITS AFFECTED?

This depend of kernel implementation installed. For lenny oficial released kernel (2.6.28) this are not affected, but backported kernel yes, due are 2.6.32 version. The squeeze release are inmediately affected due oficial release propability must be 2.6.32 o 2.6.33, of course, the backported solution for squeeze will be not affected due kernel must be greater than 2.6.34 version.

For now can use sid builds packages over 2.6.34 that fix the problem.

For etch o lenny especials, can use the kernel kanotix excalibur compilation also.
The second its that only in squeeze or sid versions that inplements these affected kernels must recompile the lvm2 and dmraid packages.

HERE IS THE KERNEL 2.6.34 for etch, lenny and squeeze (without any remotion fanatic from GNU and compatible with linux-firmwares packages) u must use module-assistant 0.11.3 if u install these linux image packages headers
linux-headers-2.6.34-4_2.6.34-4.12_all.deb
linux-image-2.6.34-4-generic_2.6.34-4.12_i386.deb
linux-headers-2.6.34-4-generic_2.6.34-4.12_i386.deb
module-init-tools_3.4-1vnz1_i386.debEste ultimo es ultra necesario, solo para etch y lenny, squeeze no lo requiere porque ya esta en debian / this lasted package are necesary in etch and lenny, squeeze can use the original from main repositories

module assistant no detecta kernel: solucion

|
El module-assistant es un paquete que pasara a la historia gracias a la reciente adición al KERNEL ORIGINAL Y UNICO de linux, del gran KMS, que en debian este paquete es supersedido por el dkms a secas!
The module-assistant is a package that going down in history with the recent addition to the original and unique LINUX KERNEL, the great KMS, which superset this package is debian for dkms as it!
 SITUACION
Sin embargo en etch, lenny o squeeze si realizamos alguna compilación o empaquetado de kerneles mas recientes de 2.6.29 el module-assistant no funciona, el problema esta aqui: http://bugs.debian.org/566487 la solución es instalar SOLO MOMENTANEAMENTE la versión de squeeze.
Esto se debe a la manera en como reporta la version del kernel y la manera en que ahora se suben las fuentes a estos ultimos paquetes de cabezeras del kernel.
Lo lamentable del asunto es que esta versión ya nolista muchos módulos fuentes de etch y algunos de lenny, por lo que si se requiere de un modulo especial para etch o lenny, deberá esperar que yo reajuste estos paquetes en la ultima y próxima versiones de massenkoh de etch, lenny y squeeze, para sarge no aplica esto ya que para poder dar soporte a módulos fuentes recientes habría que portar desde hal, hasta los mismos paquetes de fuentes.
 OVERVIEW
However, in etch, lenny or squeeze if we make any compilation or packaging for 2.6.29 or most recent kernels the module-assistant does not work, the problem here: http://bugs.debian.org/566487 the solution is to install ONLY MOMENTLY the version of squeeze.
This is because of the way is reported by the kernel version to sources builds and the way in which are now up th sources for these last kernel header packages.
Unfortunate the situation is that this version of module-assitant no list many more, some sources modules on lenny and many are removed on etch, so if it takes a special module to etch or lenny, you should expect me to reset these packages on the latest upcoming versions of massenkoh etch, lenny and squeeze. To sarge does not apply this as modules to support recent sources would have to port many packages like hal, that its very ilogic.
SOLUCION Y PROCESO

  1. Descargar el paquete de squeeze “module-assistant” solo la versión 0.11.3 recomendada.

  2. instalarlo desde el directorio donde se descargo asi: “dpkg -i ./module-assistant*.deb”

  3. volver a regeneral la cache y preparacion asi: “m-a prepare ; m-a update”
SOLUTION AND PROCESS

  1. Download the package from squeeze "module-assistant" , just 0.11.3 version recomended

  2. install it from the download directory like this: "dpkg-i. / *. deb module-assistant"

  3. Back to the cache and preparation regeneral like this: "ma prepare, ma update"
Con esto ya puede volverse a usar el module-assistant en etch, lenny o squeeze si tiene un kernel de linux mas actual de 2.6.29 o similar.
With this now can re-use the module-assistant in etch, lenny or squeeze if you have a recent 2.6.29 or greater image and headers of Linux kernel or similar.

NOTAS: muchos paquetes fueron removidos en la versión de squeeze, dado el nuevo dkms de debian que sustituira a module-assistant así que lamentablemente hasta que yo publique mis paquetes no podrá usarlo en algunos paquetes seguramente.
NOTES: many source-modules packages were removed in the version of squeeze, since dkms are new next to replace debian module-assistant so unfortunately until I publish my packages for safely, use that from squeeze on some source modules packages with not work.