Feeds, issues, packages and code source about emulation and pograming, of VENENUX proyects, Debian related distros and massenkoh!

module assistant no detecta kernel: solucion

|
El module-assistant es un paquete que pasara a la historia gracias a la reciente adición al KERNEL ORIGINAL Y UNICO de linux, del gran KMS, que en debian este paquete es supersedido por el dkms a secas!
The module-assistant is a package that going down in history with the recent addition to the original and unique LINUX KERNEL, the great KMS, which superset this package is debian for dkms as it!
 SITUACION
Sin embargo en etch, lenny o squeeze si realizamos alguna compilación o empaquetado de kerneles mas recientes de 2.6.29 el module-assistant no funciona, el problema esta aqui: http://bugs.debian.org/566487 la solución es instalar SOLO MOMENTANEAMENTE la versión de squeeze.
Esto se debe a la manera en como reporta la version del kernel y la manera en que ahora se suben las fuentes a estos ultimos paquetes de cabezeras del kernel.
Lo lamentable del asunto es que esta versión ya nolista muchos módulos fuentes de etch y algunos de lenny, por lo que si se requiere de un modulo especial para etch o lenny, deberá esperar que yo reajuste estos paquetes en la ultima y próxima versiones de massenkoh de etch, lenny y squeeze, para sarge no aplica esto ya que para poder dar soporte a módulos fuentes recientes habría que portar desde hal, hasta los mismos paquetes de fuentes.
 OVERVIEW
However, in etch, lenny or squeeze if we make any compilation or packaging for 2.6.29 or most recent kernels the module-assistant does not work, the problem here: http://bugs.debian.org/566487 the solution is to install ONLY MOMENTLY the version of squeeze.
This is because of the way is reported by the kernel version to sources builds and the way in which are now up th sources for these last kernel header packages.
Unfortunate the situation is that this version of module-assitant no list many more, some sources modules on lenny and many are removed on etch, so if it takes a special module to etch or lenny, you should expect me to reset these packages on the latest upcoming versions of massenkoh etch, lenny and squeeze. To sarge does not apply this as modules to support recent sources would have to port many packages like hal, that its very ilogic.
SOLUCION Y PROCESO

  1. Descargar el paquete de squeeze “module-assistant” solo la versión 0.11.3 recomendada.

  2. instalarlo desde el directorio donde se descargo asi: “dpkg -i ./module-assistant*.deb”

  3. volver a regeneral la cache y preparacion asi: “m-a prepare ; m-a update”
SOLUTION AND PROCESS

  1. Download the package from squeeze "module-assistant" , just 0.11.3 version recomended

  2. install it from the download directory like this: "dpkg-i. / *. deb module-assistant"

  3. Back to the cache and preparation regeneral like this: "ma prepare, ma update"
Con esto ya puede volverse a usar el module-assistant en etch, lenny o squeeze si tiene un kernel de linux mas actual de 2.6.29 o similar.
With this now can re-use the module-assistant in etch, lenny or squeeze if you have a recent 2.6.29 or greater image and headers of Linux kernel or similar.

NOTAS: muchos paquetes fueron removidos en la versión de squeeze, dado el nuevo dkms de debian que sustituira a module-assistant así que lamentablemente hasta que yo publique mis paquetes no podrá usarlo en algunos paquetes seguramente.
NOTES: many source-modules packages were removed in the version of squeeze, since dkms are new next to replace debian module-assistant so unfortunately until I publish my packages for safely, use that from squeeze on some source modules packages with not work.

1 comments/comentarios:

Anónimo dijo...

Interesante, no me hacia falta uso el dkms pero es mejor tener esos paquetes preempaquetados del module-assistant

Publicar un comentario

si vienes de guindo, winbuntu o parecido, limitate y escribe algo util...